Back to overview
Degraded
We are currently experiencing a partial degradation and are working on a fix
Apr 23 at 10:12pm EEST
Affected services
Feedback portals & widgets
Custom domains
Resolved
Apr 23 at 10:55pm EEST
We pushed out a massive update, which caused certain unexpected issues.
The issues should now be resolved, and we are continuing to monitor everything.
Affected services
Feedback portals & widgets
Custom domains
Created
Apr 23 at 10:12pm EEST
Dashboard and other services might be unavailable.
Affected services
Feedback portals & widgets
Custom domains